Among the ways health IT departments can remain prepared to incorporate new software or healthcare applications is by maintaining a robust interoperability platform. Important decision points in managing data exchange through application integration includes choosing the right interoperability vendor, and keeping the integration engine up to date with the latest available version.

Choosing the right vendor

One of the ways Corepoint Health works to stay ahead of industry trends is by participating in healthcare standards development and in multi-vendor interoperability connectathon events.

Here at Corepoint Health we’re constantly participating in trade shows, IHE USA and HL7 FHIR connectathons, and in standards creation and development at HL7 International and IHE USA. Our CTO and founder is a member of the Board of Directors at HL7 International and also plays a key role in the development of the FHIR standard as co-chair of the FHIR Governance Committee.

You can view a 2017 webinar presentation from Dave, titled, “The future of interoperability: HL7 FHIR and web APIs.”

Participation in standards development allows our organization to stay two steps ahead of industry trends as we include new standards updates in the product as they become available. Playing a leadership role in the industry also helps our development team get a head start on product features that will be perfected and tested long before they become used throughout the industry.

For example, Corepoint Integration Engine has included native FHIR support since 2014, even though it’s not yet a normative standard. This allows customers to become familiar using the standard and realize the great value it will bring to healthcare. Other examples of engine features that have been native to the software but are just now growing in use include Web Services (both RESTful and SOAP) and Direct Project.

Stay up to date

Members of the Corepoint Health Support team often field calls from customers who are having difficulties with interfaces that were previously working. A recent example included a problem with the receiving system that was not receiving data over a web service interface. The receiving system was recently upgraded and required the latest version of TLS, a web services encryption standard.

This downstream upgrade increased the requirements for a secure web services transaction. The Support representative had to inform the customer that their three-year-old version of Corepoint Integration Engine needed to be upgraded. Had they been current, there would have been no issue with the interface as the engine has supported the newer encryption standard for well over a year.

As your organization plans for IT growth, that scenario illustrates the importance of running the latest version of Corepoint Integration Engine. The new applications or technology your team chooses to implement in your IT environment will undoubtedly be the most current version. In order to quickly connect the new applications with existing applications and databases it is imperative that the integration engine have access to the latest standards and security features.

Tags: , ,
 Print Friendly